Upgrade ASA and ASDM Cisco ASA Firewall

Complete these steps to upgrade a software image on the ASA 5500 using ASDM.

1. Select Tools > Upgrade Software... from the Home window of the ASDM.
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2. Select the type of image to upload from the drop-down menu.
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3. Click Browse Local Files... or type the path in the Local File Path field to specify the location
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of the software image on your PC.



4. Click Browse Flash....

A Browse Flash Dialog window appears with the file name entered automatically. If the file
name does not appear, enter it manually in the File Name field. Click OK when you are done.
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A Status window appears while ASDM writes the image to Flash.
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Once completed, an Information window appears that indicates a successful upload.
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Click OK in the Information window and then Close in the Upload Image from Local PC
window.

Choose Configuration > Properties > Device Administration > Boot Image/Configuration >
Edit in order to change the boot image location.



Configuration = Prope Diece Administration = Boot ImagesConfiguration

4~ Startup Vizard |4 Boot ImageConfiguration
+ % B Sebup - -
Ak rifigura
1 H;—Spﬂnﬁng Corifigure boot Images from sh ectarnal TETP sarver ard flssh fle systemn. Uk B0 faw knages can be confipured
L= e Upsate fio the book systern, Only ore TRTP oot image can be configured. The TFTP koot image, if configured, must ks
B Clirt Lot the first image inthe st
= Cerificate

Boct Orelsr Bt Image Lacstion e

F il Devics Access
=38 Device Administration i = et
— = Bariner

&) clock

g Consoie
50 Setup

3 Davice

i FTP haock e Py

Il g

_-' ICMP Fulez
b Maragement Soc
e Boot Contig Fie Path:
L Paamword 2 I Eriavves Flash...

—ﬂ Sacure Capry —‘
v e |

=MTP :
 ASDM Corfiguration
g SIMP e

all TFTP Server ASDM Image Fie Paih ]:i:kl] Jasdm-521 hin Erowse Flash, .
il Uner Acoountz

Click Browse Flash in order to choose or specify the ASA image file. Then click OK.
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8. Choose File > Save Running Configuration to Flash in order to store the configuration to
Flash memory.
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9. Choose Tools > System Reload from the Home window to reload the device.
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10. A new window appears that asks you to verify the details of the reload. Select Save the
running configuration at the time of reload and then choose a time to reload.
o Now—Reboot the device immediately.
o Delay By—Specify in how many minutes or hours from now to reload the device.
o Schedule at—Specify a time and date to reload the device.

You can also specify whether or not the device should force a reload immediately if a
scheduled reload fails. Check On Reload failure, force an immediate reload after and then



specify a maximum hold time. This is the amount of time that the security appliance waits to
notify other subsystems before a shutdown or reboot. After this time elapses, a quick
(forced) shutdown/reboot occurs. Click Schedule Reload.
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11. Once the reload is in progress, a Reload Status window appears that indicates that a reload
is being performed. An option to exit ASDM is also provided.

Note: Start ASDM again after the ASA reloads.
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Upgrade an ASDM Image using ASDM 5.x
Complete these steps to upgrade an ASDM image on the ASA 5500 using ASDM.
1. Choose Tools > Upgrade Software... from the Home window of the ASDM.
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2. Select the type of image to upload from the drop-down menu.
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3. Click Browse Local... or type the path in the Local File Path field to specify the location of

4.

the ASDM image on your PC.
Click Browse Flash....

A Browse Flash Dialog window appears with the file name entered automatically. If the file
name does not appear, enter it manually in the File Name field. Click OK when you are done.
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5. Once both the local and remote file names are specified, click Upload Image.
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A Status window appears while ASDM writes the image to Flash.
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Once completed, an Information window appears that indicates a successful upload.
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Click OK in the Information window and then Close in the Upload Image from Local PC

window.
Choose Configuration > Properties > Device Administration > Boot Image/Configuration in
order to change the ASDM image file name in the configuration.
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Click Browse Flash in order to choose or specify the ASDM image file. Then click OK.
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8. Choose File > Save Running Configuration to Flash in order to store the configuration to
Flash memory.
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9. Choose Tools > System Reload from the Home window to reload the device.
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10. A new window appears that asks you to verify the details of the reload. Click Save the
running configuration at the time of reload and then choose a time to reload.
o Now—Reboot the device immediately.
o Delay By—Specify in how many minutes or hours from now to reload the device.
o Schedule at—Specify a time and date to reload the device.

You can also specify whether or not the device should force a reload immediately if a
scheduled reload fails. Check On Reload failure, force an immediate reload after and then
specify a maximum hold time. This is the amount of time that the security appliance waits to
notify other subsystems before a shutdown or reboot. After this time elapses, a quick
(forced) shutdown/reboot occurs. Click Schedule Reload.
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11. Once the reload is in progress, a Reload Status window appears that indicates that a reload
is being performed. An option to exit ASDM is also provided.

Note: Start ASDM again after the ASA reloads.
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Dan't showe this dislog again. To viewe reload status inthe future, go to Tools = System
Feload and click the Details button.

Reftesh | Force Imtnediste Relosd | Exit ASD

Upgrade a Software Image with ASDM 6.x
Note: ASDM 6.x is supported only on ASA software image 8.x and later.
Complete these steps to upgrade a software image on the ASA 5500 with ASDM:

1. Choose Tools > Upgrade Software from Local computer... from the Home window of the
ASDM.
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2. Choose the type of image to upload from the drop-down menu.
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minutes, Please wait for the operation ko finish,
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3. Click Browse Local Files... or type the path in the Local File Path field to specify the location
of the software image on your PC. The file path in Flash File System is automatically
determined and shown. If the file path in Flash File System is not shown, you can type it
manually or click Browse Flash and choose the path.
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Once both of the file paths are specified, click Upload Image. A Status window appears
while ASDM writes the image to Flash.
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Once completed, an Information window appears that indicates a successful upload and
asks to set this image as boot image. Click Yes if you want the new image to be set as boot
image; otherwise click No.
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If you click Yes, it sets the new image as the boot image, and a Information box appears.
Click OK.
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8. A new window appears that asks you to verify the details of the reload. Choose Save the

running configuration at the time of reload, and then choose a time to reload.
o Now—Reboot the device immediately.
o Delay By—Specify in how many minutes or hours from now to reload the device.
o Schedule at—Specify a time and date to reload the device.

You can also specify whether or not the device must force a reload immediately if a
scheduled reload fails. Check On Reload failure, force an immediate reload after, and then
specify a maximum hold time. This is the amount of time that the security appliance waits to
notify other subsystems before a shutdown or reboot. After this time elapses, a quick
(forced) shutdown/reboot occurs. Click Schedule Reload.



Once the reload is in progress, a Reload Status window appears that indicates that a reload
is being performed. An option to exit ASDM is also provided. Click Exit ASDM, and restart
ASDM after the device reloads.
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Con't show this dialog again. To wiew reload status in the Future, go ko Tools = Syskem
Reload and click the Details butkon.

Reftesh | Force Immediate Reload | Exit A50M |

Upgrade an ASDM Image with ASDM 6.x
Note: ASDM 6.x is supported only on ASA software image 8.x and later.
Complete these steps to upgrade an ASDM image on the ASA 5500 with ASDM:

1. Choose Tools > Upgrade Software from Local Computer... from the Home window of the
ASDM.
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IUpload a file from local computer to Flash File system on the device, The upload process might take a Few

rminutes, Please waik Far the operation ko finish,

Image to Upload;
Local File Path:

Flash File System Path:

Application Profile Customization Framework, {F'.F‘CF}j

Application Prafile Customization Framewark (APCF)
frats)

Client Secure Deskbop (C30)
Cisco AnyConnect YRR Clienk

Upload Image I

Close | Help

Browse Local Files, .. |

Browse Flash, .. |

3. Click Browse Local Files... or type the path in the Local File Path field to specify the location

of the ASDM image on your PC. The file path in Flash File System is automatically
determined and shown. If the file path in Flash File System is not shown, you can type it
manually or click Browse Flash and choose the path.
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IJpload a file from local computer to Flash file system on the device, The upload process might take a Few
minutes. Please wait For the operation to Finish,

Image to Upload: IASDI"-’I j

Local File Path: IC:'I,F'ru:ugram Files! Tftpd32Yasdm-603. bin ¢ Browse Local Files, ..

Flash File System Paths; Idiskl:l:,l'asdm-EuDS.l:uin

Browse Flash, ..

Upload Image Close Help

4. Once both of the file paths are specified, click Upload Image. A Status window appears
while ASDM writes the image to Flash.

&= Upgrade Software . : -

Uplaad & File §% Status X

e afew
minutes, Ple

Flease wait while 850M is uploading the file, The upload
Immage ko U E process may take a Few minutes,

Local File Pz il Files. ..

Flash File 5

|
T

5. Once completed, an Information window appears that indicates a successful upload and

asks to set this image as the default an ASDM image. Click Yes if you want the new image to
be set as the ASDM image; otherwise click No.

&= Upgrade Software

Image has been uploaded ko flash successfully, Do wau wank ko sek this image as
@ the A30M image?

| Opioad IMage | L (a1 I Iy [=]]n] I

6. If you chose Yes to use the new image as the ASDM image, an Information box appears.
Click OK.



E= Information

@ Your dewvice configuration is updated ko use the new image.

To use this A30M image, you will need ko exit and rerun ko 8500, Click the Save

button in the koolbar if wou want ko save this change in flash and make it
permanent,

File Wiew Took Wizards Window Help

E@ s '3%' Configur ation Ea Monitoring | _'

(¥ refrech | a Back ﬂﬂ‘rmrd | @ Hnlp|
o Flash | 2

= Save Funning Configuration
Home
-ﬁ —
= | "B Device Dashboard | € Firewal Dashboard |
E Device Information Interface Status
il General i Licerse | Interface
CMZ
Hosk Mame:  CiscoASA.cisco.com | o
L {inside

8. A dialog box appears for your confirmation. Click Apply.

E:'&_ Save Running Configuration to Flash

i": Do wou want to save the running configuration ko flash memory?

Zancel |

9. Click File on top of window, and choose Exit to close ASDM.
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@ Are you sure vou want o exit Cisco ASDM?
Click Yes bo exit A30M or Mo bo continue using &S0,
v always display this dialog before exiting Fram A50M,

[

11. Run ASDM again to load the new ASDM image.

Refer to this video for more information: How to upgrade the software image on a Cisco
Adaptive Security Appliance(ASA) using Cisco Adaptive Security Device Manager (ASDM)



https://supportforums.cisco.com/videos/2353
https://supportforums.cisco.com/videos/2353

